Vorbereitungen auf die 0.9er Version laufen an

Sheera Khan
Sheera Khan
 Moderator edited July 20 in Announcements
Huhu liebe Metrolaner, Dear Metro-residents (for an english version please look a bit further down)

unsere MetroEdition 0.83Plus hat uns schon sehr lange treue Dienste geleistet, aber die Entwicklung ist nicht stehen geblieben. Eine ganze Reihe von Neuerungen, Verbesserungen und Fehlerbehebungen ist in den letzten Jahren vorgenommen worden und immer mehr Einwohner hier wollen diese gerne nutzen. Das geht aber nur, wenn wir auch die Grid-Services entspechend anpassen. Daher beginnt Zak mit Unterstützung des Admin Teams mit dem Testgrid als Probelauf, und mit den Anpassungen, die die MetroEdition eben für unsere Verhältnisse (DynDNS usw.) einfacher einsetzbar macht. Das Testgrid wird daher in den nächsten Tagen öfter wieder on- und offline sein, da dort fleißig gebastelt wird :-)

Ich möchte in dem Zusammenhang daran erinnern, dass das Metro-Grid nur aus Spenden betrieben wird und dass die Server trotz der Sommer-Flaute weiterhin betrieben und auch bezahlt werden müssen. Spenden werden gerne entgegengenommen ;-) Spendenseite

Habt immer einen kühlen CaiPi in eurer Nähe - Ciaoo

Sheera

-------------------- english -----------------------------

OpenSimulator 0.8.3 was a good and stable release and our Metro-Edition did serve us well for nearly two years. But we want  to get the benefits of nearly two years of development to our residents. According to the developer meetings (office hour transscripts are here) the devs aren't exactly pushing to tag a certain commit of the source code as a stable release - that is mostly a political issue and not so much of a technical one. So we have to work on our own... In a first step we are evaluating a current snapshot for its use as grid services. To keep your valuable assets safe we use the MetroTest-grid which is entirely separate from our main grid. There we do some load tests and look for potential issues with migrating a database from 0.8.3 to 0.9.1 After we are reasonably confident that there won't be any avertable issues we will roll out the grid-services on the main grid. At the current time there is a lot of compatibility code in the 0.9.1 to support older simulators as region servers so we expect all regions on 0.8.2+ to work with the newer grid services. To make use of the new features and the performance gains of 0.9.1 one would need to upgrade the region server to a new release too. The MetroRelease for regions will be published on our website after thorough testing.

So please don't be too alerted if the testgrid is offline at times - there may be some busy admins at work ;-) The main- and the testgrid are supported by donations only. Even though it is summertime and some residents enjoy some RL quality time now... please consider the servers are running still and need to be fed. So a donation is always appreciated :-)

Have a great time  - Ciaoo

Sheera

Comments

  • Manfred Aabye
    Manfred Aabye
     Member
    Da bin ich ja mal gespannt :)
    Hoffentlich nicht diese öde und lahme 0.9.0 die keiner will.
  • Eryn Galen
    Eryn Galen
     Moderator CreativeGroup
    @Zak Spot Wenn es gewünscht ist, helfe ich gerne beim Testen.
    Meldet euch einfach, dann packe ich eine alte Version von Hogwarts auf das Testgrid, damit es so richtig ausgelastet ist ;)
  • Lena Vanilli
    Lena Vanilli
     Administrator
    @Eryn Galen Die Hogwarts-Regionen gepaart mit Franzi's Inventar: Der ultimative Belastungstest! :) 

  • floro123
    floro123
     Member
    Hello, I am doing tests with this version 0.9.1 in metropolis and right now I want to continue testing my regions

  • Sheera Khan
    Sheera Khan
     Moderator
    Hi Floro,

    we have no issues with your testing. Quite some of the new features aren't availlable though until the grid services are upgraded to 0.9.1 too. Those we will be testing thoroughly in the testgrid. The main-grid will get those updates when we are as confident as possible not to break stuff unneccessarily.

    The roll-out of a MetroEdition for the regions will happen after all that and we will announce the new download accordingly when it is availlable

    Ciaoo

    Sheera.
    Thanked by: floro123
  • floro123
    floro123
     Member
    Thanks I install that version because there is privacy in the plots , And looking forward to the new metropolis version :)


  • Eryn Galen
    Eryn Galen
     Moderator CreativeGroup
    @Eryn Galen Die Hogwarts-Regionen gepaart mit Franzi's Inventar: Der ultimative Belastungstest! :) 

    Genau! Aber notfalls tut es mein Inventar von mittlerweile über 30K Objekten auch ;)
  • Mareta Dagostino
    Mareta Dagostino
     Member edited July 24
    Wie kommt man eigentlich mit dem Firestorm Viewer ins Metro-Testgrid rein? Der übliche Weg bringt eine Fehlermeldung:



    Ansonsten gibt es noch die Möglichkeit, die Gridinformationen hart in die Steuerdatei vom Firestorm reinzutexten, also die <username>/.firestorm_x64/user_settings/grids.user.xml zu editieren. Gestern hatte ich verschiedene Varianten erfolglos durchprobiert. Könnte mir vielleicht jemand mit Zugang zum Testgrid den entsprechenden XML-Block aus seinem/ihrem Rechner rauskopieren? Als Beispiel zur Erklärung, was ich meine, hänge ich mal den XML-Block des Metropolis Maingrids dran. Also das Testgrid-Äquivalent zu dem da suche ich:
        <key>hypergrid.org:8002</key>
    <map>
    <key>LastModified</key>
    <date>2013-04-02T01:01:24.65Z</date>
    <key>about</key>
    <string>http://www.hypergrid.org/metropolis/wiki</string>;
    <key>gatekeeper</key>
    <string>hypergrid.org:8002</string>
    <key>gridname</key>
    <string>Metropolis Metaversum</string>
    <key>gridnick</key>
    <string>Metropolis</string>
    <key>help</key>
    <string>http://metropolis.hypergrid.org/forum</string>;
    <key>helperuri</key>
    <string>http://metropolis.hypergrid.org/currency/helper/</string>;
    <key>login_identifier_types</key>
    <array>
    <string>agent</string>
    <string>account</string>
    </array>
    <key>loginpage</key>
    <string>http://metropolis.hypergrid.org</string>;
    <key>loginuri</key>
    <array>
    <string>http://hypergrid.org:8002/</string>;
    </array>
    <key>name</key>
    <string>hypergrid.org:8002</string>
    <key>password</key>
    <string>http://metropolis.hypergrid.org/password.php</string>;
    <key>platform</key>
    <string>OpenSim</string>
    <key>register</key>
    <string>http://www.hypergrid.org/metropolis/metro_rg.php</string>;
    <key>slurl_base</key>
    <string>hop://hypergrid.org:8002/</string>
    </map>
    Viele Grüße,
    Mareta

  • Sheera Khan
    Sheera Khan
     Moderator
    Huhu Mareta,

    ich vermute, die Testgrid-Services sind gerade down. Da werden wir Zak mal fragen müssen ;-)

    Ciaoo

    Sheera
  • Mareta Dagostino
    Mareta Dagostino
     Member
    Danke Sheera, das war's. :)
  • frost
    frost
     Member
    Huhu.. I tried to add a new sim running 0.9.0.0 to the production grid. Copied all the url's for the grid services etc to the fresh config. However, on start-up I get this:

    23:02:18 - [GRID SERVICE]: Region Linkwater_Hyperplane (93337752-ebfb-4a85-85d6-ecc082c931ba, 256x256) registered at 6870,6870 with flags RegionOnline
    23:02:18 - [GRID CONNECTOR]: RegisterRegion received null reply when contacting grid server at http://hypergrid.org:8002/grid
    23:02:18 - [STARTUP]: Registration of region with grid failed, aborting startup due to Error communicating with the grid service at http://hypergrid.org:8002/grid  ; at OpenSim.Region.Framework.Scenes.Scene.RegisterRegionWithGrid () [0x00000] in <filename unknown>:0
      at OpenSim.OpenSimBase.CreateRegion (OpenSim.Framework.RegionInfo regionInfo, Boolean portadd_flag, Boolean do_post_init, IScene& mscene) [0x00000] in <filename unknown>:0

    Am I doing something wrong, or is the production grid not ready yet to connect 0.9.0.0 sims?

  • frost
    frost
     Member
    frost said:


    Am I doing something wrong, or is the production grid not ready yet to connect 0.9.0.0 sims?

    Yes, you are doing something wrong. You had an invalid GridServerURI set you dummy.

  • Mareta Dagostino
    Mareta Dagostino
     Member
    The production grid accepts 0.9.x regions, but actually itself is a 0.8.3 grid. That means, no extra 0.9 grid features are supported now. (Region only 0.9 features work of course.)

    There is a test grid with the latest nightly builds, which supports all 0.9 specials. But as it is from nightly builds, there is no guarantee if it comes up each day, and all assets may be lost if strange things happen.
Sign In or Register to comment.

Welcome

It looks like you're new here. If you want to get involved, click one of these buttons!

Discussions

© Copyright 2017 - Metropolis Metaversum
All times are GMT