Avatar cannot Access Region - Microsoft KM-TEST Loopback Adapter

UncleHamdi
UncleHamdi
The process of actually setting up the region was very easy. However, I installed NAT Loopback not quite as suggested in the guide since the only available Loopback was named Microsoft KM-TEST Loopback Adaptor and I configured everything and followed the instructions. Everything would appear to be set up correctly with the settings asking the Loopback to automatically find the IP address. Unfortunately NAT Loopback cannot find the IP address on my machine and just keeps trying to find it without success making it impossible for me to resolve. Has anyone come across this before I wonder?
«1

Comments

  • Eryn Galen
    Eryn Galen
     Moderator CreativeGroup
    I have not encountered that before. However if you would like help then if you get an error message it would help if you post that.
  • UncleHamdi
    UncleHamdi
     Member edited September 15
    Hello Eryn and thank you. There is no error message as such. NAT Loop tool that I have installed continuously attempts to find my IP address even though automatically assign boxes are ticked. So, I open cmd prompt for the Nat Loop Tool and can see that it keeps trying over and over to find my computer IP address. 

    If I got to  Network and Sharing Center", choose "Properties", then go to the "Internet protocol Version 4 (TCP/IPv4) there is nothing for me to compare it with as per Metropolis instructions. Automatically assign IP address is blank but if I click on the link https://hypergrid.org/my_external_ip.php is has no trouble providing me with my IP address.

  • UncleHamdi
    UncleHamdi
     Member
    Oh well, time to move on elsewhere. After spending hours on this I admit defeat. I got as far as getting a region running on the grid but was unable to resolve the particular NAT Loop issue I had. I even went down the route of static IP and dyns but I failed. I think opensim software is very much a case of it might work and it might not. I have a brand new PC with good spec and everything needed was installed and up to date. I spent most of the day trying to go over the instructions again and again without any joy. Time to try this on a another grid I think. One day opensim software just might work - out of the box! 
  • Mareta Dagostino
    Mareta Dagostino
     Member
    Hi Hamdi,

    if you can pay 8-10 € monthly, probably a virtual server in a data center could be a good investment. First your region can be online all time, which would have energy costs of nearly the same amount at home. Second you get a real static IP address.

    These days really many home routers lack the feature of "NAT Loopback", and many people have huge problems to solve that.

    Regards,
    Mareta
  • Pius Noel
    Pius Noel
     Member
    UncleHamdi schrieb:
    Hello Eryn and thank you. There is no error message as such. NAT Loop tool that I have installed continuously attempts to find my IP address even though automatically assign boxes are ticked. So, I open cmd prompt for the Nat Loop Tool and can see that it keeps trying over and over to find my computer IP address. 
    Just checked back using the wget tool manually. There seems to be an issue with the wget tool and the handling of the certificate. 

    I tried with 'wget -O - %URL%'  and got certificate verification errors instead of my external IP. I'm not sure why this happens. I tried both, with http:// and https:// in the URL environment variable.

    Changing 'wget -q -O - %URL%' to 'wget --no-check-certificate -q -O - %URL%' resolved the issue (it's on line 23 in NAT_Loopback_Tool.bat).

    Maybe someone can apply a fix in one or the other way.
  • Pius Noel
    Pius Noel
     Member
    A small but remarkable detail: on Windows http://hypergrid.org/my_external_ip.php returns my IPv4 address when used with wget (from the NAT loopback tool), but my IPv6 address when used from the browser.
    However, I had only IPv4/IPv6 related issues with Opensim/Metropolis at the time my provider introduced IPv6 without prior notification.
  • JardelGreggan
    JardelGreggan
     Member edited September 20
    I also discovered, as you PIUS, that my problem in not being able to access a region created on my PC, was for a change, without notice, by my IPv6 provider. According to the METROPOLIS tutorial only requesting the provider to switch to IPv4, because the grid does not work with IPv6, I believe it is only in the opensim that make possible the creation of regions in PC (own server). My provider refuses to make a change saying that it is not possible to do so, that is, after 2 years of using 4 beautiful regions 512x512, I feel I lost them, unless GRID updates and works with IPv6, since the IPv4 is in the process of extinction around the world.
  • Eryn Galen
    Eryn Galen
     Moderator CreativeGroup
    Hi Jardel,
    I believe this is not an issue for a single grid, but is inherent in OpenSim itself.
  • Mareta Dagostino
    Mareta Dagostino
     Member edited September 21
    Yes as Eryn has said, OpenSim at all does not support IPv6. My provider switched to IPv6 years ago. My solution - as written above - is to use a rented server. There is no option to run OpenSim regions without IPv4 at all and that behaviour is the same in all OpenSim grids. And no grid can do anything to solve that, only further development of OpenSim itself and also the OpenSim Viewers (!) would help.
  • Eryn Galen
    Eryn Galen
     Moderator CreativeGroup
    Hihi @Mareta: Your provider switched to Opensim? Great!
  • Mareta Dagostino
    Mareta Dagostino
     Member
    Yeah, but OpenSim Version 4.0 with IPv6, now I must wait for that release. :D

    (corrected above)
  • JardelGreggan
    JardelGreggan
     Member edited September 21
    Hi Mareta! I believe that some Grids already run Opensim with ipv6, because with this same modem that is enabled only with IPv6 I can access regions that I have in the OSGRID and Grid of the Adreans easily. That is, even with the exchange for IPv6 in my modem, I keep opening the ports relative to the regions that I have in these grids and therefore I can access them. Or we are faced with a riddle.
  • JardelGreggan
    JardelGreggan
     Member
    But I have solved my problem, since I can access the regions that I have in my PC created by the opensim of METROPLIS. I will try to explain, I have two PCs, one is still enabled with IPv4 (same provider), so I have the other pc connect through this other modem, through a network cable, I open the ports then configuring through this modem and squeeze the regions now on the PC where I have them. Problem solved. But the other modem because it is another point of the NET provider has been idle and this does not look good.
  • Pius Noel
    Pius Noel
     Member
    JardelGreggan schrieb:
    Hi Mareta! I believe that some Grids already run Opensim with ipv6, because with this same modem that is enabled only with IPv6 I can access regions that I have in the OSGRID ...
    No, OSGrid does not support IPv6.

    I guess your provider has implemented some kind of Dual Stack Lite, where private IPv4 packets in the equipment at your side are encapsulated into IPv6 packages before they are routed to your provider. At the providers side they are converted back into IPv4 packages and provided with routable public addresses. Think about NAT at the providers side (actually it's called carrier graded NAT). If this is the case I'm wondering how you can reach your OSGrid regions from outside.

    There are many different IPv4/IPv6 Dual Stack and Dual Stack Lite implementations. Not all work the same and the options they provide as well as their results may vary.
  • JardelGreggan
    JardelGreggan
     Member
    But you're commenting on an evaluation error Plus Noel, if that were the case with this same modem with some facets of the provider's permissions, I would also access my islands created on my pc in METROPOLIS GRID, and this does not happen or insist several times.
Sign In or Register to comment.

Welcome

It looks like you're new here. If you want to get involved, click one of these buttons!

Discussions

© Copyright 2017 - Metropolis Metaversum
All times are GMT