Suche eine ältere Metro-Linux-Version 0.8.3

Slow Ibanez
Slow Ibanez

Hallo zusammen, ich benötige mal eine ältere Metro Software für Linux 0.8.3 gerne
auch mal eine 0.8.2. Grund.: mit der aktuellen Version von der Webseite habe ich Probleme auf meinem V-Server (Debian 8 und 9, 10 Kerne, 50 GB RAM), z.B.: oar upload von ca. 80 MB dauert ca. eine Stunde, ich sehe dann auch im Land Info das eine Anzahl von Objekten verbraucht ist, nur sind diese Objekte nicht sichtbar. :o Exakt die gleiche Datei auf meinem Home dauert das Hochladen etwa 5 Minuten und alles ist sofort sichtbar. Habe es auch in einem anderen Grid versucht, dort geht es auch fix, ebenfalls 5 Minuten für den upload. Ich habe zwei Tage alles versucht, habe keine Idee mehr. Danke


Liebe Grüße

Slow

Comments

  • Sheera Khan
    Sheera Khan
     Moderator
    Huhu Slow,

    hier ist schon mal die Download-Adresse:


    Das ist die aktuelle 0.8.3-MetroEdition.

    Alles Gute und viel Glück

    Sheera
  • Lena Vanilli
    Lena Vanilli
     Administrator
    Huhu Slow,

    hier gibts die Version 0.8.2 von Ende 2015: http://hypergrid.org/download/metropolis-os_082_DEV_PLUS_WINDOWS.zip

    Sag dann mal Bescheid, ob sich dein Problem damit erledigt hat.

    Viele Grüße
    Lena

  • Slow Ibanez
    Slow Ibanez
     Member
    Danke euch beiden. Sheera, natürlich weiß ich wo die aktuelle Version zu finden ist ;), wie ich aber im Titel schon schreibe suche ich eine ältere Version. Liebe Lena, dein Link geht zu einer Windows Version, kann ich diese auch für Linux benutzen?

    LG
    Slow
  • Pius Noel
    Pius Noel
     Member
    Ich habe noch eine metropolis-os_082_DEV_PLUS_LINUX.zip vom 20. Oktober 2015. Die Grösse der gezippten Datei ist 29'270'022 Bytes, das sind gerade mal 64 Bytes weniger als die von der Windows Version.

    Ich habe die Datei für den Download auf meinen zur Zeit inaktiven privaten Web Server gestellt:
    https://petergloor.ch/downloads/metropolis/metropolis-os_082_DEV_PLUS_LINUX.zip

    Ich werde die Datei nach einer Woche wieder löschen.
  • Pius Noel
    Pius Noel
     Member
    Falls es sich um ein normales mit Opensim 0.8.3 kompatibles OAR handelt, denke übrigens nicht, dass das Problem mit der Opensimulator Version zu tun hat.

    Ich habe soeben ein OAR von 120 MB mit 654 Scene Objects, bestehend aus 1530 Assets und einem Landimpact von 3731 in die Single Region swamp auf Metropolis hochgeladen und das dauerte weniger als 4 Minuten.

    Am Ende des Uploads sind allerdings Fehler im Zusammenhang mit NPCs aufgetreten (unpack failed badly: Index was outside the bounds of the array) die im OAR enthalten sind und in der Folge nicht rezzen.

    Der Server ist eine einfache VM mit Ubuntu 18.04, mono 4.6.2 und Maria-DB (mysql) auf einem Server bei Hetzner in Falkenstein.
  • Slow Ibanez
    Slow Ibanez
     Member edited August 30

    Guten Tag, gibt es noch andere Andere Angebote ? Vor drei Tagen liefen meine Regionen auch einwandfrei, wollte dann unter Debian 8 mal einen Snapshot machen, dabei fiel mir auf das dort eine Meldung stand, das es mit Debian 8 und Snapshots Probleme gibt. Habe daraufhin Debian 9 genutzt. Also die 0.8.3 von der Webseite geladen und neu installiert, es gab dann oben beschriebene Probleme. Da alles mit Debian 8 alles problemlos funktionierte hab ich also alles Rückgängig gemacht.


    Wegen der langen oar upload Zeit habe ich alles auf Fehler meinerseits überprüft und das ganze dreimal wiederholt, mit dem immer gleichen Ergebnis. Dachte mir ist sicher bei der oar-Sicherung was schief gelaufen, also das oar auf meinem Home hochgeladen (Windows), klappte alles gut.


    Daraufhin habe ich alles wieder gelöscht (Metro Version) und die Version 0.9.1 (Linux) aus einem anderen Grid geladen und diese genutzt, oar dort hochgeladen (OSG), funktionierte auch problemlos. Tja und und nun bin ich ein wenig konfus :)


    Kann mir auch nicht vorstellen das es an der Metro Version liegt, vielleicht hat  jemand eine andere Lösung, das Kuriose ist; wenn ich auf meiner Region lande lädt weder mein Avatar komplett, noch sehe ich Objekte gerezzt obwohl im Landinfo an die 500 Objekte "angezeigt" werden.


    LG
    Slow






  • Slow Ibanez
    Slow Ibanez
     Member edited September 3
    Der nächste Versuch, bin wieder zurück auf Debian 8, Mono Version 3.2.8 . Mein Mini oar von ca. 80 MB lädt nach einer Stunde immer noch, das Terrain ist zwar sofort da aber weiter tut sich garnix, im oar sind einige Meshteile, vielleicht sagt das ja jemandem was. Habe gleiches oar, nur zum testen, wieder in OSGrid hochgeladen, diesmal waren dort sämtliche Objekte schon nach zwei Minuten gerezzt. Was kann das denn sein, ich weiß echt nicht mehr weiter.

    Grüße Slow
  • Mareta Dagostino
    Mareta Dagostino
     Member edited September 3
    Hallo Slow,

    mit einer alten Metro-Version kann ich zwar nicht dienen. Hast du eine feste, statische IPv4 Adresse oder einen Dienstleister, der deine dynamisch zugeteilte IPv4 Adresse automatisch einer festen (Sub-)Domain zuteilt? Dann kannst du statt einer Metro-Edition auch beliebige "offizielle" OpenSim Versionen nehmen ab der Version 0.8.2 aufwärts. Lediglich werden die  neuen gridseitigen Features der 0.9.x Versionen noch nicht unterstützt, was bezüglich der von dir beschriebenen Probleme unerheblich ist. Solltest du eine Version finden, die auf deinem Betriebssystem zufriedenstellend läuft, nimmst du halt die.

    Für 0.8.x Versionen: http://opensimulator.org/dist/

    Statt der 0.9.0.x empfehle ich aber aktuelle Versionen aus dem OS-Grid, weil die seitdem deutlich verbessert wurden. http://danbanner.onikenkon.com/osgrid/

    Viele Grüße,
    Mareta
  • Slow Ibanez
    Slow Ibanez
     Member edited September 6
    Hallo Mareta, danke für den Tipp. Welche Dateien muss ich denn anpassen, Ports und was weiß ich noch.? Oder ist es ausreichend wenn ich die opensim.ini und gridcommon.ini von der Metro Version nehme?
  • Mareta Dagostino
    Mareta Dagostino
     Member
    Sorry, ich war im Urlaub. Falls es noch relevant ist: Ich empfehle, die ini-Dateien vom OS-Grid gründlich durchzugehen und nicht einfach blind die Dateien gegen die Metro-Inis zu tauschen. Je nach Version (insbesondere 0.9.x) wird das (etwas) unterschiedlich konfiguriert. Du kannst aber ruhig mit den Metro-Inis beginnen und ggf. fehlendes ergänzen, das ist bequemer als andersrum.

    Wichtige Stellen der Metro-Konfiguration:

    Unter "0.9" habe ich die gleichen Abschnitte in der Anleitung mal fürs OSgrid konfiguriert, das kannst du zum Vergleichen hernehmen. Allerdings habe ich damit nur einen Kurztest gemacht. Früher wurden im Forum ausführlich verschiedene Konfigurationsvarianten diskutiert, und ich konnte die Anleitung optimieren. Jetzt wird das wohl anderswo kommuniziert, entsprechend möchte ich nicht die Hand ins Feuer legen, dass meine Konfiguration performant ist. Mit meiner Konfiguration kam eine Testregion hoch, ansonsten benutze ich selber noch keine 0.9.
Sign In or Register to comment.

Welcome

It looks like you're new here. If you want to get involved, click one of these buttons!

Discussions

© Copyright 2018 - Metropolis Metaversum
All times are GMT