Confused when setting up Hypergrid

Daniel
Daniel
Hey peeps,

I'm stuck with my Simulator. I have a Diva Installation (unluckily still 0.8.2.1) running on a dedicated server. Diva enabled Hypergrid by default, thus there is nothing much to do there. I set my Server_IP as my EXTERNAL_IP and paid attention to have appropriate region coords (they are in the range from 7000-8000). The SIM has port 9010 and my regions are continuously starting from 9011.
As I have no router in between, I don't mind port_forwarding on my Debian system.

I can easily jump into Metro but trying to find my server in the map is failing each time. I obviously missed anything, got some hints?

Btw, logging into my World does work like a charm.

Thanks and regards,

Daniel

Comments

  • Mareta Dagostino
    Mareta Dagostino
     Member edited February 8
    Hi Daniel,

    you could try the following for test:
    a) Examine what is your actual real external IPv4, for example with http://www.ip-adress.eu/
    b) Change EXTERNAL_IP to the actual real IPv4 everywhere in the config files where your IP is necessary. (With some luck Diva uses variables to allow a central one-place setting.)

    If you have a static IPv4 address it could be that you are ready.

    If you have a dynamic IPv4 and it works now, the problem is solved only temporary. The Metropolis edition (the download from Hypergrid.org) has a special implementation of EXTERNAL_IP, which emulates the functionality of a dynamic DNS (also called DDNS) service. Most other OpenSim distributions don't have that. So you need an external DDNS provider. If such a setting is set up, you can fill their subdomain name in the place(s) of the EXTERNAL_IP in the config file(s). That's much work and sometimes users are not successful with that setup.

    If the test above fails, some other or additional problems are in the config.

    Kind regards,
    Mareta

    EDIT: Another more simple test, ask a friend from outside of your home network to visit your own grid. If others (from outside) can reach your regions, forget what I wrote above.


  • Daniel
    Daniel
     Member
    Hi Mareta,

    thanks for your answer.

    My SIM is outside of my home network ;)

    The static IP is correct, I counterchecked to only have the correct IP in my config files.

    Maybe it's important to mention that I have another SIM running on Port 9000 and subsequent. But this should not matter I guess. That installation does not have HG enabled.

    Cheers
  • Mareta Dagostino
    Mareta Dagostino
     Member
    Hi again,

    if you are not in the same home network as your server, the things I wrote above do not correlate with your problem. But if you have more than one OpenSim.exe running simultaneously on the server, they must not use the same HTTP Port. You can change one of them in the OpenSim.ini, by removing the ; and changing it to 9001 for example.
    [Network]
    ; http_listener_port = 9000
    Of course the same applies for all the region ports of both OpenSim instances running on the machine, they should differ all.

  • Daniel
    Daniel
     Member
    The listener_port is different for both and does not interfere.

    Today I will make up a new Diva-SIM and try. Maybe I oversee any change I made in the current config. I'll keep you informed.
  • Daniel
    Daniel
     Member edited February 9
    thanks
  • Daniel
    Daniel
     Member
    Daniel said:
    The listener_port is different for both and does not interfere.

    Today I will make up a new Diva-SIM and try. Maybe I oversee any change I made in the current config. I'll keep you informed.
    Default installation didn't change a thing. Still there an issue somewhere.
  • Han Held
    Han Held
     Member
    Did you make sure that you have opened up the right ports in your firewall? In Linux (Debian, Ubuntu) I normally use UFW and run the following:
    sudo ufw allow proto tcp from any to any port 8000:8010,9000:9200
    sudo ufw allow proto udp from any to any port 8000:8010,9000:9200

    Change to fit whatever ports you intend to use. :)
  • Daniel
    Daniel
     Member
    I just opened my firewall for all incoming - JUST QUICKLY TO TEST! - restored my previous settings immediately ;)
    But even then I could not reach my Simulator. This is so frustrating, as there shouldn't be any problem
Sign In or Register to comment.

Welcome

It looks like you're new here. If you want to get involved, click one of these buttons!

Discussions

© Copyright 2017 - Metropolis Metaversum
All times are GMT