Could not teleport. Service request failed: Invalid URI: Invalid port specified.

Lucy Afarensis
Lucy Afarensis
I am trying to move my sim to a different server. It boots normally but I get the above error when I try to teleport to it and I get this error:
 :
 Could not teleport.
Service request failed: Invalid URI: Invalid port specified.

Comments

  • Sheera Khan
    Sheera Khan
     Moderator
    Hi Lucy,

    could you please take a look at your region in our region management tool https://metropolis.hypergrid.org/regioman.php? Are the ip address and port mentioned there correct? If not, please stop your opensim server, delete the entry in the region manager and start your region again. If the parameters are indeed correct check for an active firewall blocking the ports.

    Ciaoo

    Sheera

  • Lucy Afarensis
    Lucy Afarensis
     Member
    I am still getting the same error.. I deleted the entry as you suggested as the address was an ipv6 and I am not sure what it is. I am using the ipv 4 for my region assignment. I have no conflicts with other sims running on the server. The ports are open. When I have shut the server down it does not completely shut down
  • Sheera Khan
    Sheera Khan
     Moderator edited February 12
    OpenSim on IPv6 just doesn't work according to to our experience. If your server doesn't depend on an IPv6 configuration you can disable it from the command line by issuing the following command as root:
    echo 1 > /proc/sys/net/ipv6/conf/all/disable_ipv6
    This is a temporary measure and will be gone after the next reboot and is just intended to check if all other services are still working correctly without IPv6. I f you are positively sure IPv4 is everything you need you can make that change permanent by putting the following line into the file /etc/sysctl.conf:
    net.ipv6.conf.all.disable_ipv6 = 1
    Depending on the Linux distribution you use there might be a file or directory better suited for this line but it should work for now. After a reboot IPv6 will be permanently disabled. Should you ever need it again you only have to delete or comment out that line and reboot again.

    The shutdown not fully completing is an issue of OpenSim with some mono releases and not that big a deal, you can terminate the process using CTRL C or using the command kill.

    I hope that helps you solve your issue - Ciaoo

    Sheera


  • Lucy Afarensis
    Lucy Afarensis
     Member edited February 14
    echo 1 > /proc/sys/net/ipv6/conf/all/disable_ipv6
    it worked !

    Why was this not a problem with the osgrid sims on the same server ?
  • Mareta Dagostino
    Mareta Dagostino
     Member edited February 15
    There is no OpenSim grid in the world which works with IPv6, because OpenSim itself can use only IPv4. Totally disabling IPv6 is hard core of course, but you can eliminate one possible error source this way.

    If you do not share the same HTTP port or the same UDP region ports, hosting multiple instances of OpenSim.exe (in different "bin" directories and with different databases) connected to different grids on the same server is possible.

    Maybe you find some more details of your problem? "Could not teleport.
    Service request failed: Invalid URI: Invalid port specified." is very general because this error message the viewer throws on each and every kind of problem...
    What, for example, happens in the OpenSim console of the region while an avatar tries to teleport to the region? Is there eventually no reaction because of closed ports?
  • Lucy Afarensis
    Lucy Afarensis
     Member
    Disabling IPv6 did solve my problem. Sheera in her first reply to me asked me to check the server URI in region managment. It showed an IPv6 address for some reason, So I do not know if it is a bug on my end or yours. The console did not show anything when I tried to teleport. Region management now shows the correct IPv4 address and everything works
    Thanked by: Pius Noel
  • Mareta Dagostino
    Mareta Dagostino
     Member
    Thank you for the reply, Lucy! (And nice to read that it works now.)
Sign In or Register to comment.

Welcome

It looks like you're new here. If you want to get involved, click one of these buttons!

Discussions

© Copyright 2018 - Metropolis Metaversum
All times are GMT