Stimmt etwas nicht?

Kxirya Weytana
Kxirya Weytana
Huhu zusammen,

ich stelle gerade fest, dass auf allen unseren Regionen (auch nach mehrmaligem Neustart) offenbar Scripte nicht (richtig) kompiliert werden können.
Wenn ich auf "Speichern" klicke, dauert es mehrere Minuten, bis ich die Fehlermeldung bekomme, dass die Upload Anfrage nicht bearbeitet werden kann.

Außerdem werden dynamisch erzeugt Texturen offenbar nicht erstellt, bzw. an das Prim übertragen.

Ich hoffe nicht, dass "die Russen " gerade wieder herumprobieren :/

Grüße.

Comments

  • Lena Vanilli
    Lena Vanilli
     Administrator
    Huhu Kxirya,

    nicht das ich wüsste. Vielleicht hat es einen temporären Engpass gegeben. Das passiert ab und zu, wenn mehrere Leute größeres Inventar hochladen. Meine Tests (gerade eben) verliefen ohne Beanstandungen.

    Liebe Grüße
    Lena

  • Kxirya Weytana
    Kxirya Weytana
     Member edited June 12
    Ich werde das nachher nochmal testen, aber gestern hatten wir das Problem auf 3 verschiedenen Servern, davon 2 "Heimserver" und unser Pangea Server. Daher schließe ich aus, dass 3 Rechner und 6 Regionen den selben Fehler haben.
    Auch ein Neustart der Regionen hat nichts verändert.

    Edit:
    Gerade eben über eine andere Internetleitung mit einem anderen PC getestet. Ergebnis:
    Ich kann vorhandene Scripte nicht ändern / hochladen /kompilieren und kann keine neuen erstellen.
    Nach einigen Minuten erscheint die Meldung, dass das Script (UUID) nicht hochgeladen werden kann, da die Upload Anfrage nicht funktioniert hat.

     Grüße.

  • Kxirya Weytana
    Kxirya Weytana
     Member
    So, ich habe eine Lösung gefunden, kann aber keine Rückschlüsse auf den Fehler an sich geben, denn es passierte ja auf mehreren Rechnern, auf unterschiedlichen Regionen und mit unterschiedlichen Internetleitungen.

    Vielleicht kann aber anderen, die vllt. dieses Problem auch mal haben  könnten, geholfen werden.

    Ich habe das Prim, bei dem dieser Fehler ZUERST auftrat (Script kann nicht gespeichert werden), ins Inventar genommen (NICHT kopiert!), bin dann off gegangen und habe die Region nochmals neu gestartet.

    Nach dem Neustart loggte ich mich dort wieder ein und erstellte zuerst einen Würfel mit einem "Neuen Script" und siehe da, dieses funktionierte auf Anhieb.

    Dann holte ich das zuvor ins Inventar gelegte Prim mit dem scheinbar fehlerhaften Script zurück auf die Region, öffnete das "Übeltäterscript" und kompilierte es neu.

    Täterätää, es läuft nun wieder und lässt sich auch wieder wie gewohnt ändern und speichern.

    Dennoch wäre ich dankbar, wenn mir jemand erklären (ich weiß, man kann da wohl nur vermuten) kann, was da passiert sein könnte.

    LG

    Kxìrya te Weytana Nllteya'ite 
  • Lena Vanilli
    Lena Vanilli
     Administrator
    Tut mir Leid. Da fällt mir auf die Schnelle auch nix ein, woran es gelegen haben könnte. Mögliche Ursachen könnte ich schon aufzählen: 

    - ein nicht konsistenter Cache ( einer von den 4) ;)
    - Asset-Server mit OAR- oder IAR-Uploads zugeballert; dadurch Timeouts bei den Clients
    - amoklaufende Scripte
    - usw.

    Das ist wie die Suche nach der Nadel im Heuhaufen. Da Testszenarien aufzubauen und / oder in der Source nach Ursachen zu suchen übersteigt unsere Möglichkeiten. Ich denke auch, dass manches im Quellcode begraben ist. Dafür haben sich im Laufe der Jahre zu viele Dilettanten am OpenSim ausgelassen, als das sie irgendwann einmal einen halbwegs fehlerfreien Stand haben könnte.  Deswegen wird es auch nie eine 1.0-Version vom OpenSim geben.

    Wir dilettantieren halt weiter und machen das Beste draus. ;)
  • Kxirya Weytana
    Kxirya Weytana
     Member
    Naaaa, Lena... Nicht so pessimistisch XD
    Das Glas ist nicht halb leer, aber auch nicht halb voll - Es kann aufgefüllt werden XD

    Ich schreibe hier ja nicht einfach, weil ich Lust auf Meckern habe, sondern versuche selber und mit Hilfe anderer de kleinen und großen Problemchen zu lösen.

    Daher versuche ich auch immer durch Feedback meine 'Erfahrungen' weiter zu geben, denn so mancher kleine Hinweis in einer Sache kann früher oder später den Durchbruch in einer ganz anderen Sache bedeuten.

    Daher hoffe ich, dass 'Meckereien' von mir, wie diese, nicht persönlich genommen werden. Ich versuche halt konstruktiv zu sein. Ob mir das allerdings immer gelingt, kann ich selber nicht so beurteilen.
  • Lena Vanilli
    Lena Vanilli
     Administrator
    Huhu Kxirya,

    ich finde das richtig, dass du sofort nachfragst, wenn etwas nicht so läuft wie es sollte. Vielleicht haben andere ähnliche Probleme und man kann evtl. Strukturen oder Übereinstimmungen erkennen. Aber meistens sind solche Probleme zeitlich begrenzt und erledigen sich quasi von selbst. ;)

    Es geht aber auch anders: anfangs 2018 hatte das Grid wegen einer permanent amoklaufenden Instanz wochenlang Performance-Probleme. Nur: der Maschinenraum wusste nix davon. Es hatte sich Niemand gemeldet! Deswegen mussten alle für Wochen mit einer schlechten Performance leben. Erst nachdem sich dann Jemand gemeldet hatte, ist die Instanz in wenigen Minuten identifiziert und neu gestartet worden. Das war jetzt ein Negativ-Beispiel in Richtung "still sein". ;)

     




Sign In or Register to comment.

Welcome

It looks like you're new here. If you want to get involved, click one of these buttons!

Discussions

© Copyright 2017 - Metropolis Metaversum
All times are GMT