Nat-Loopback

Lindalou Ellisson
Lindalou Ellisson
Hallo zusammen, ich bräuchte ganz dringend Hilfe, ich habe wieder das Problem mit der Loopback. In meinem Router (Telekom, Speedboard W921V) lässt sich leider NAT-Loopback nicht einstellen.
Wer kann mir helfen was ich wo runterladen, einstellen, einrichten muss. Das ganze unter Windows 10, 64 bit. Leider kann ich kein englisch und mit dem PC kenne ich mich auch nur begrenzt aus, was ich brauche ist eine gute Anleitung (für blöde , hihi). 
Vielen Dank im voraus und liebe grüße
Linda

Comments

  • Lena Vanilli
    Lena Vanilli
     Administrator
    Huhu Lindalou

    hier ist eine Anleitung  zu diesem Thema. Bezieht sich zwar auf Windows 7, aber es sollte genauso im Windows 10 funktionieren. Wenn wir demnächst die Webseite erneuern, werden wir auch eine aktuelle Anleitung hinterlegen. ;)

    https://hypergrid.org/metropolis/wiki/de/index.php?title=NAT_Loopback_Router

    Liebe Grüße
    Lena

  • Manfred Aabye
    Manfred Aabye
     Member edited October 28
    Du brauchst kein Loopback aktivieren, dein Router unterstützt alles auch Dynamisches DNS, Handbuch Seite 135.


    Thanked by: Pius Noel
  • Lindalou Ellisson
    Lindalou Ellisson
     Member
    Hallo Manfred, Lena
    also ich habe die DNS aktiviert, läuft einwandfrei, auch habe ich Nat Loopback hier auf meinem PC unter Win 10 auch aktiviert. doch ich komme immer noch nicht auf meine Region die ich hier auf meinem Home PC installiert habe. Ich habe die Möglichkeit zu Testzwecke mit einer fremden IP ins Internet zu kommen. Hier schaffe ich es auf meine Region zu kommen, ergo scheint es eindeutig dieser Loopback Efekt zu sein . Was könnte ich noch versuchen . Wenn ihr mal auf meine Region gehen wollt (sie ist z:Z.  leer) dann such nach Mentis Pacem Neu. Neu ist wichtig da meien Heimatregion Mentis Pacem auch gibt. Liebe Grüße Linda

  • Lindalou Ellisson
    Lindalou Ellisson
     Member
    noch ein Nachtrag: wenn ich im Geräte.Manager, Netzwerkadapter,Loopbackadapter den Reiter  Erweitert aufschlage  so steht da der Eintrag Eigenschaften: Netzwerkadresse und ein Wert. Welschen Wert (ip) trage ich da ein ? 
    Des weiteren : Unter Netzwerkeigenschaften anzeigen sehe ich bei dem Loopback adapter den Hinweis: Verbunden mit unbekanntem Netzwerk, kein Datenverkehr.
    Wie muss ich das Interpretieren ?
    Gruß Linda

  • Pius Noel
    Pius Noel
     Member
    Hallo Linda.
    noch ein Nachtrag: wenn ich im Geräte.Manager, Netzwerkadapter,Loopbackadapter den Reiter  Erweitert aufschlage  so steht da der Eintrag Eigenschaften: Netzwerkadresse und ein Wert. Welschen Wert (ip) trage ich da ein ? 
    Bei mir steht da nichts drin, das Feld ist leer.

    Lindalou Ellisson schrieb:
    Des weiteren : Unter Netzwerkeigenschaften anzeigen sehe ich bei dem Loopback adapter den Hinweis: Verbunden mit unbekanntem Netzwerk, kein Datenverkehr.
    Das ist bei mir auch so, das scheint mir eher bedeutungslos zu sein. Wichtig ist hingegen, dass bei IPv4-Adresse die externe IPv4 Adresse drin steht.

    Ich komme übrigens von aussen problemlos auf deine neue Region.
  • Pius Noel
    Pius Noel
     Member
    Nachtrag: ich habe den NAT Loopback schon längere Zeit nicht mehr benutzt und stelle gerade fest, dass ich damit auch Probleme habe.

    Ich bin mir aber nicht sicher ob es sich um die gleichen Probleme handelt, denn ich komme zwar auf die neue Region, aber nicht mehr weg, wenn ich einmal dort bin. 

    Leider kann ich dem vor Freitagabend nicht nachgehen.
  • Pius Noel
    Pius Noel
     Member
    In meinem Fall hat das Problem jetzt dran gelegen, dass ich seit nicht allzulanger Zeit eine neue Antivirus Software mit Firewall-Funktionalität benutze, die meine internen Verbindungen zur externen IP-Adresse (Loopback) blockiert hat. Während ich die Firewall vorübergehend kurz abgeschaltet habe, hat es funktioniert.
  • Pius Noel
    Pius Noel
     Member
    Manfred Aabye schrieb:
    Du brauchst kein Loopback aktivieren, dein Router unterstützt alles auch Dynamisches DNS, Handbuch Seite 135.


    Ich muss zugeben, ich bin jetzt überrascht: es funktioniert bei mir tatsächlich auch ohne Loopback Adapter. Ich habe zwar einen anderen Router (Internet Box von Swisscom), aber alles was notwendig war, ist die richtige Weiterleitung der Ports am Router und die richtige Konfiguration der Firewall unter Windows 10. Bei meinem alten Router war das ohne Loopback Adapter nicht möglich.
  • Lindalou Ellisson
    Lindalou Ellisson
     Member
    Hallo, also ich weiß immer noch nicht was ich machen soll ich bekomme es einfach nicht ans laufen, Loopback Adapter ist eingerichtet sowhol auf einem wind 10 wie auch win 7 Pc , im Roter habe ich allemöglichen Ports eingetragen, bleibt immer noch die Meldung im Loopbackadapter " Nicht indentifiziertes Netzwerk" Hab nun keien Plan mehr ... Ich habe das alles so installiert wie auf Seite 135 beschrieben , trotzdem negativ.
    Gruß Linda

  • Data Rossini
    Data Rossini
     Member edited November 1
    Hallo Lindalou,
     hatte auch mal das gleiche Problem mit dem NAT Loopback (Hairpin NAT) oder wie es auch immer genannt wird. Hatte zuhause unter Linux einen OpenSim Server installiert, einen Account bei einem dynamischen IP-Dienst eingerichtet und die für OpenSim nötigen Ports auf dem Router freigegeben. Aber es lief drotzdem nicht, so wie ich es wollte. Der Server war zwar von außen erreichbar, aber jedoch nicht  intern im Heimnetz über die Dyndns-FQDN (z.B. "mein -server.dyndns.org..." o.ä.) . Es lag damals an der Firmware des Berliner Router Herstellers nach einem Firmwarewechsel. Ist aber bestimmt fast 10 Jahre her.  Aber nach dem sich nicht wenige Kunden beklagt hatten, haben die sich dem Problem angenommen. Ich selber bin vermutlich bei der gleichen Netzbetreiber Firma,  verwende aber nicht deren Router, sondern nutze seit über 10 Jahre eine Fritzbox (zur Zeit 7490). Mitunter auch wegen der umfangreicheren Einstellmöglichkeiten und weil da halt NAT Loopback funktioniert.
     
     Habe gegoogelt und auch etwas zur eventuellen Problemlösung gefunden.

    - Tabelle der OpenSim tauglichen Router für Heimserver. Sieht aber im Moment ungepflegt aus.
      http://opensimulator.org/wiki/NAT_Loopback_Routers

     - manche sind der Meinung es sollte nur IP 4 verwendet werden.

     - zwar ein anderer Routertyp, aber aktuell (22.04.2018, W724V, gelöst) und vom gleichen Netzbetreiber.
       https://telekomhilft.telekom.de/t5/Geraete-Zubehoer/Implementierung-von-Hairpin-NAT-aka-NAT-Loopback/td-p/1045322/page/25

    Drück Dir die Daumen.

    Data
  • Lindalou Ellisson
    Lindalou Ellisson
     Member
    Hallo,
    nach zahlreichen Bemühungen komme ich zum Schluss, dass das Problem warum ich nicht auf meien Region komme im Router zu suchen ist. Daher habe ich mich entschlossen mir einen anderen Router zuzulegen, Wer kann mir sagen welsche Fritzbox am besten geeignet ist ? 
    Gruß Linda

  • Pius Noel
    Pius Noel
     Member edited November 5
    Es tut mir leid, dass ich auch nicht weiterhelfen konnte. Im Prinzip müsste es mit dem Loopback Adapter funktionieren. Wenn ich ihn aktiviere, dann sieht das zwar auch so aus wie bei dir (kein Netzwerk etc.) aber spätestens wenn ich mich zu meiner lokalen Region teleportiere werden auch Pakete über diesen Adapter geroutet.

    Ich fasse nochmals zusammen:
    1) Firewall von meinem AntiVirus machte ohne Anpassung Probleme; die von Windows funktioniert.
    2) Meine OpenSim Version ist OpenSim 0.8.3.0 Dev PLUS Metropolis Edition [018].
    3) NAT Loopback Adapter von Microsoft installiert und Batch ausgeführt.
    4) Kontrolliert, ob die aktuelle IPv4 Adresse im Loopback Adapter gesetzt ist.
    5) Wichtig: in der Regions.ini:
        InternalAddress = 0.0.0.0
        AllowAlternatePorts = False
        ExternalHostName = SYSTEMIP

    Welche FRITZ!Box in deinem Fall die richtige ist, kann ich leider auch nicht sagen. Das hängt auch vom Provider und dem Anschluss ab. Es wird hier bestimmt jemand geben, der genauere Auskunft geben kann. @Data Rossini erwähnte die FRITZ!Box 7490. Oder AVM anrufen: +49-30-399 76-696 und dich beraten lassen. Übrigens: soweit ich weiss, kann man bei TELEKOM die FRITZ!Box auch mieten.
Sign In or Register to comment.

Welcome

It looks like you're new here. If you want to get involved, click one of these buttons!

Discussions

© Copyright 2018 - Metropolis Metaversum
All times are GMT