Anpassung ans Metro...

brenner23
brenner23
Hallo hab mal eben eine Source 0.8.2 aus der OpenSim.org gezogen und mal Compiliert,
Dann die ini-dateien aus dem vorhandenen Metrosimulator rübergezogen....

Bei dem Simulator bekomme ich ne Fehlermeldung beim start , Koorrnaten sind frei !

: Registration of region with grid failed, aborting startup due to Could not load type of field 'System.Net.HttpWebRequest:tlsProvider' (49) due to: Could not resolve type with token 0100004a from typeref (expected class 'Mono.Security.Interface.MonoTlsProvider' in assembly 'Mono.Security, Version=4.0.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756') assembly:Mono.Security, Version=4.0.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756 type:Mono.Security.Interface.MonoTlsProvider member:(null)   at OpenSim.Framework.SynchronousRestObjectRequester.MakeRequest[TRequest,TResponse] (System.String verb, System.String requestUrl, TRequest obj, System.Int32 pTimeout, OpenSim.Framework.ServiceAuth.IServiceAuth auth) [0x00001] in <e077ee2c28284c48b218085436487b57>:0
  at OpenSim.Framework.SynchronousRestObjectRequester.MakeRequest[TRequest,TResponse] (System.String verb, System.String requestUrl, TRequest obj, OpenSim.Framework.ServiceAuth.IServiceAuth auth) [0x00001] in <e077ee2c28284c48b218085436487b57>:0
  at OpenSim.Services.Connectors.AssetServicesConnector.Get (System.String id) [0x00038] in <a3b010285e084de3b5bb76d351dd7941>:0
  at OpenSim.Region.CoreModules.ServiceConnectorsOut.Asset.HGAssetBroker.Get (System.String id) [0x00082] in <3b7a087e31c54aa09ff717fdb154af93>:0
  at OpenSim.Region.CoreModules.World.LegacyMap.TexturedMapTileRenderer.fetchTexture (OpenMetaverse.UUID id) [0x00019] in <3b7a087e31c54aa09ff717fdb154af93>:0
  at OpenSim.Region.CoreModules.World.LegacyMap.TexturedMapTileRenderer.computeAverageColor (OpenMetaverse.UUID textureID, System.Drawing.Color defaultColor) [0x00033] in <3b7a087e31c54aa09ff717fdb154af93>:0
  at OpenSim.Region.CoreModules.World.LegacyMap.TexturedMapTileRenderer.TerrainToBitmap (System.Drawing.Bitmap mapbmp) [0x000c2] in <3b7a087e31c54aa09ff717fdb154af93>:0
  at OpenSim.Region.CoreModules.World.LegacyMap.MapImageModule.CreateMapTile () [0x000fa] in <3b7a087e31c54aa09ff717fdb154af93>:0
  at OpenSim.Region.CoreModules.World.WorldMap.WorldMapModule.GenerateMaptile () [0x00030] in <3b7a087e31c54aa09ff717fdb154af93>:0
  at OpenSim.Region.Framework.Scenes.Scene.RegenerateMaptile () [0x00010] in <5a30fdf4896947f9b83bfc6c321b8d46>:0
  at OpenSim.Region.Framework.Scenes.Scene.RegisterRegionWithGrid () [0x00018] in <5a30fdf4896947f9b83bfc6c321b8d46>:0
  at OpenSim.OpenSimBase.CreateRegion (OpenSim.Framework.RegionInfo regionInfo, System.Boolean portadd_flag, System.Boolean do_post_init, OpenSim.Framework.IScene& mscene) [0x001d7] in <0ca3ad8db07a485a88f0d48e3b654ad8>:0

Kann mir mal jemand sagen wo der fehler liegen könnte ?


Comments

  • Data Rossini
    Data Rossini
     Member edited November 30
    Hallo brenner23,
    nehme mal an es gibt Probleme mit der verwendeten Mono-Version.
    So wie es für mich aussieht, verwendest Du eine Mono Version > 4.0, mit der es Probleme gibt.
    Unter Linux lässt sich die Version auf der Konsole mit "mono --version" ermitteln.
    Ich selber habe auch vor kurzem eine "opensim-eb988d7_0.8.2-post-fixes_2016-07-03" gezogen.
    und unter Linux mit der relativ alten, aber sehr stabilen Mono Version 3.0.6 kompiliert. Die hatte ich auch vorher schon lange Zeit mit der aktuellen Metro-Version problemlos am laufen.

    LG



  • Pius Noel
    Pius Noel
     Moderator edited November 30
    Das ist jetzt für mich auch nicht ganz nachvollziehbar. Ich habe mit der aktuellsten Version von Mono (5.16.0.220) versucht ein git checkout von 0.8.2-post-fixes (eb988d7) mit msbuild zu erstellen und das ging (wie von mir erwartet) nicht. Ich wiederholte den Vorgang mit xbuild, was funktionierte (duckt sich und zu Manfred blickt).

    Anschliessend habe ich auch die .ini's einer bestehenden Installation hergeholt und alles funktionierte.

    Ich möchte bei dieser Gelegenheit noch darauf hinweisen, dass die Versionen von opensimulator.org nicht zu 100% den Metropolis Editionen entsprechen, die noch ein paar Erweiterungen haben.

    Nachtrag: ich muss noch darauf hinweisen, dass bei mir alle 0.8.n Versionen das Problem haben, dass mit neueren Mono Versionen (> 4.2.1) unter Ubuntu der Simulator beim Shutdown hängen bleibt. Es gibt einen Fix, der jedoch erst in den neueren 0.9-er Versionen enthalten ist, aber auch nicht in allen Fällen funktioniert (hängt von den verfügbaren Resourcen ab). Ich kann die Aussage nur für Ubuntu 16.04 und höher machen. Wie es sich bei anderen Distributionen verhält, weiss ich nicht.
  • brenner23
    brenner23
     Member edited December 2
    Mono version :
     mono -V
    Mono JIT compiler version 5.16.0.179 (tarball Thu Oct  4 10:24:32 UTC 2018)
    Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
            TLS:           __thread
            SIGSEGV:       altstack
            Notifications: epoll
            Architecture:  amd64
            Disabled:      none
            Misc:          softdebug
            Interpreter:   yes
            LLVM:          yes(3.6.0svn-mono-/)
            GC:            sgen (concurrent by default)

    Musste ich aus beiträgen und erfahrungen zwecks complieren und co mal erneuern , das Debian 9.5 Stretch hat nur ne alte Version aus dem Apt mitbekommen :-)

    Nachtrag:
    Offizielles Metro Download, OSG Download und mein Testgrid laufen auf dem server...
    Ich kann ja nochmal spasseshalber ne 0.9 Stable von meinem Grid die Inis auf Metro anpassen.....
    Aber ich denke mit der Letzten 0.8.2_1 Stable sollte eigenlich mit Metro laufen, da 0.8.3.....

    Zum Thema mono version werde ich noch ein paar Zeile schreiben...
    Da geht es um Compilieren und DTL moneymodul... die Probleme beim Compilieren bei Alter Mono Version....

    lg



    Thanked by: Pius Noel
  • brenner23
    brenner23
     Member
    Hallo Hab mich gerade hier Geäussert...
    Ich bin mal auf die Aktuelle 0.9.x gegangen und mal die Inis von Metro drübergeschoben...
    läuft :-)


Sign In or Register to comment.

Welcome

It looks like you're new here. If you want to get involved, click one of these buttons!

Discussions

© Copyright 2018 - Metropolis Metaversum
All times are GMT