Umfrage: Anleitung für OpenSim 0.8 Regionenserver (nicht Arriba) noch nötig?

Mareta Dagostino
Mareta Dagostino
Hallo,

Lage: Im Frühjahr möchte ich meine Webseite mit dem Tutorial neu aufsetzen. Da frage ich mich, ob überhaupt noch jemand OpenSim 0.8 einsetzen wird, wenn Metropolis umgestellt ist? Die jetzt noch verfügbare OpenSim "Metropolis-Edition" ist eine leicht modifizierte 0.8.3, gepflegt wird die zukünftig wohl nicht mehr. Ebenso hat das OSgrid noch eine alte 0.8.3 gesichert, die ist schon lange ungepflegt. Die letzte "offizielle" 0.8.2.1 von OpenSimulator.org ist nur mit sehr alten Mono-Versionen kleiner als Mono 4.2 lauffähig. Der Support für Ubuntu 14.04 läuft im Mai aus. Danach wird Centos 7 die einzige bekanntere Linux-Distribution sein, die noch ein hinreichend altes Mono hat. (Man kann recht leicht auf aktuellere Mono-Versionen upgraden, aber ein Downgrade unter die von der Distribution vorgesehene Version ist wegen der Abhängigkeiten ein arges Gebastel.)

Frage: Kennt ihr noch Leute, die in irgendwelchen Grids ihre Regionen mit OpenSim 0.8 anschließen wollen? Sonst würde ich nämlich auf der neuen Webseite den Part für OpenSim 0.8 auf OpenSim Arriba umstellen, den einzigen noch weiter gepflegten 0.8'er Fork.

Liebe Grüße,
Mareta
Thanked by: Pius Noel

Comments

  • [Gelöschter Benutzer]
    [Gelöschter Benutzer]
    Der Nutzer und alle zugehörigen Inhalte wurden gelöscht.
  • Lena Vanilli
    Lena Vanilli
     Administrator
    Wie @Mareta Dagostino schon schreibt, wird die Metro mit der DB-Eindampfung auf 0.9 umstellen. Wir werden dann auch eine Metro-Version des OpenSim 0.9 zur Verfügung stellen und die "alte" 0.8.3-Version nicht mehr supporten. 

    @brenner23 : mach dir keine Gedanken über die Metro! Es wird sie auch weiterhin geben und wird auch weiterhin offen für extern gehostete Simulatoren / Regionen sein. Wir versuchen auch wie immer ganz nah am Standard zu bleiben und besondere Features als AddOns zu gestalten. Damit sollten für die User auch vorbereitende Anpassungen auf 0.9 nicht vergebens sein.

    Liebe Grüße
    Lena
  • Mareta Dagostino
    Mareta Dagostino
     Member
    Hallo Brenner,

    das OSgrid verwendet bereits eine 0.9.1 Entwicklerversion, und nur für die 0.9.1 braucht man zwingend ein ziemlich modernes Mono (oder .NET bei Windows). Die derzeitige Release 0.9.0.1 von OpenSimulator.org (wo auch die Metro-Edition von abgeleitet wird) kommt mit den bisherigen Mono-Versionen klar.

    Es geht mir hier in der Umfrage um die vielen kleinen Grids da draußen, die ich nicht kenne: Braucht da noch jemand meine alte Anleitung für 0.8, oder benutzen die eh längst Arriba? Wir in der Metro werden von den Admins eine 0.9-Metro-Edition bekommen. Und sobald ich die neue Software in die Finger kriege, werde ich schon die derzeitige Anleitung entsprechend anpassen ... da braucht kein Metro-Resident bis ins späte Frühjahr für warten.

    Liebe Grüße,
    Mareta
  • Copper Tomsen
    Copper Tomsen
     Member
    Könnte man das ggf. für weniger technisch versierte erklären was da gemeint ist? Ich hab sims auf meinem Rechner ja angeschlossen mit der SQlite von Metro oder wie das heißt. Hat das was damit zu tun?
  • Sheera Khan
    Sheera Khan
     Member edited January 11
    Hallo Copper,

    Mareta stellt dankenswerterweise sehr detaillierte Anleitungen bereit, wie man OpenSim- bzw. Arriba-Server für Regionen einrichtet und an offene Grids anbindet. Leider unterscheiden sich die verschiedenen Versionen z.T deutlich in ihrer Konfiguration, so dass ein gewisser Pflegeaufwand mit den Tutorials verbunden ist. Um die Website übersichtlich zu halten und nicht übermäßig viele Blöcka a la "Bei der Version X müssen Sie dies machen, bei der Version Y dagegen jenes..." fragt Mareta nach, ob die ältere 0.8er OpenSim noch eingesetzt wird.

    OpenSim-Versionen
    0.8.x        erprobte Software, der aber etliche neuere Features fehlen - u.a. die derzeitige Metro-Edition
    Arriba      Fork der 0.8.x OpenSim-Software durch Freaky Tech. Der Quellcode wurde bereinigt und die Performance gesteigert. Die Konfiguration weicht aber tlw. von der der MetroEdition ab.
    0.9.0.x    Inzwischen auch schon mehrere Jahre alte stabile Version der OpenSim-Software.
    Die vorgenannten Varianten laufen auch auf Uralt-Distributionen und sogar auf Windows XP (erinnert sich noch jemand daran?)
    0.9.1.x   Aktueller Entwicklungszweig der OpenSim-Software mit den coolen neuen Bugs aber eben auch den neuen Features wie z.B. "Ani-What?", dem Gegenstück zu SLs neuem Animesh ;-) Diese Version erfordert zwingend ein moderneres .NET-Framework (mind. Windows 7 *schluck*) bzw. das UNIX/Linux Gegenstück Mono in einer Version ab 5.x.

    Die neueren Entwicklungsversionen 0.9.1.x weisen zunehmend Inkompatibilitäten zu den älteren 0.8.x Versionen auf, so dass gelegentlich die TPs unzuverlässiger laufen, Attachments beim TP nicht mitkommen, Texturen grau bleiben usw. so dass man nicht unbegrenzt lange auf "seiner" alten Version bleiben sollte.

    Jede OpenSim-Software Version definiert ihre speziellen minimalen Systemvoraussetzungen, zu denen u.a. auch die Versionsnummer desDatenbanksystems gehört.

    Datenbanken
    Jede OpenSim Instanz benötigt unabhängig von der Version für die Verwaltung ihrer Daten eine Datenbank. Diese Datenbank ist dabei wiederum vollkommen unabhängig von der Software, die das Grid einsetzt. Alle o.g. Versionen unterstützen dabei die:
    SQLight          Sehr einfach einzurichten aber recht begrenzt in der Performance und Einschränkungen beim Umfang der Daten. Wird aber mitgeliefert, um eine einfache Testinstallation zu ermöglichen.
    MySQL           Weit verbreitete performante Datenbank
    MariaDB        Fork der MySQL Datenbank und von der Konfiguration her identisch mit MySQL
    PostgreSQL High-Performance System für große Datenbanken, aber aufgrund der weitaus geringeren Verbreitung gelegentlich auftretende Fehler bei neuen Versionen durch mangelnde Erprobung
    MSSQL            SQL-Datenbank von Microsoft, ab der 0.9.1.x nicht mehr unterstützt, da eine Umfrage keinen praktischen Einsatz dieser DB feststellen konnte.

    Regionen vs. Grids
    Maretas Tutorials beschränken sich auf die Konfiguration von Regionsservern. Die Einrichtung eines Grids erfordert weitere Schritte und die vom Grid verwendeten Software Versionen korrelieren nicht zwingend mit den Versionsständen der Regionen, Man kann durchaus 0.9.0.x und 0.9.1.x Regionen in einem 0.8.3-Grid betreiben - und etliche Metropolaner machen dies auch erfolgreich. Allerdings fehlt an einigen Stellen dann die Unterstützung durch das Grid und die neueren Features funktionieren dann evtl. nicht. Umgekehrt lässt sich auch eine 0.8.3-Region in einem 0.9.x Grid betreiben. Sie bleibt dann aber auf die Features der 0.8.3 beschränkt. Weiter zurückliegende Regionen (0.7.x) werden dagegen nicht mehr unterstützt.

    Puhhh, ich hoffe, ich konnte da etwas Licht in die Sache bringen ;-)

    Ciaoo

    Sheera


  • Copper Tomsen
    Copper Tomsen
     Member
    Wow..zunächst einmal vielen Dank für die Vereinfachung der Information. Ich kann also zunächst einmal die bisherige Metro Version weiter (be-) nutzen, bis dann via Metro Homepage eine neuere kommt? Ist das richtig so? Ich benutze die sims ja nicht so extensiv ... Eher mal um mehr die Konsole zu lernen usw. Wäre schön wenn dann eine so genial beschriebene , und somit auch für "low techies" , verständliche Version noch verfügbar bliebe. Wie immer die auch dann heißt ^^
  • Mareta Dagostino
    Mareta Dagostino
     Member edited January 11
    Ja @Copper Tomsen, für Motropolitaner bleibt technisch alles wie gewohnt. :) Es wird eine neue OpenSim Metropolis Edition geben, die dann zum neuen V0.9 Grid kompatibel ist. Da wird wieder wie bisher oben in der GridCommon.ini erklärt sein, was unbedingt eingestellt werden muss (die Datenbank). Der Rest an Konfigurationen ist freiwillig für jene, die speziellere Dinge vor haben. Die Regions.ini Datei kann sogar einfach kopiert werden.

    Hier im Thread geht es mir um alte OpenSim Versionen.


  • Copper Tomsen
    Copper Tomsen
     Member
    Puh..Danke ;-)
Sign In or Register to comment.

Welcome

It looks like you're new here. If you want to get involved, click one of these buttons!

Discussions

© Copyright 2019 - Metropolis Metaversum
All times are GMT