No connection to Metropolis grid

Taarna_Welles
Taarna_Welles
 Member edited August 24 in Technical Support

Hello Lena,


As you know I have the region Savvy on Metropolis.

Our router firewall passes ports 9000-9100 to our own server.

When we login we can connect fine to the home region of Metropolis.

But if we want to teleport to Savvy the teleport fails.

The opensim server software logs this message on each teleport :

 

2019-08-21 13:07:59,440 ERROR - OpenSim.Framework.Servers.HttpServer.BaseHttpServer [BASE HTTP SERVER]: HandleRequest() threw exception

System.FormatException: Input string was not in a correct format.

   at System.Number.ParseSingle(String value, NumberStyles options, NumberFormatInfo numfmt)

   at OpenMetaverse.Vector3.Parse(String val)

   at OpenSim.Server.Handlers.Simulation.AgentHandler.DoQueryAccess(Hashtable request, Hashtable responsedata, UUID agentID, UUID regionID)

   at OpenSim.Server.Handlers.Simulation.AgentHandler.Handler(Hashtable request)

   at OpenSim.Framework.Servers.HttpServer.BaseHttpServer.HandleContentVerbs(OSHttpRequest request, OSHttpResponse response)

   at OpenSim.Framework.Servers.HttpServer.BaseHttpServer.HandleRequest(OSHttpRequest request, OSHttpResponse response)

 

Since all settings on our side appear correct, we ask you to reports any problems or changed settings which may cause this behavior.

 

We look forward to your reply.

Best,

Taarna

Comments

  • Neovo Geesink
    Neovo Geesink
     Member
    • Hello Taarna.
    the 1st Region of a Home OpenSim Server should be at 9050
    Any more regions should be on successive numbers like 9051, 9052, ...

    At first, Ferify, and correct the next points if NOT true:

    • Do you use the Metropolis version of OpenSim?
    • Have you forwarded BOTH TCP and UDP ports 9000 AND 9001, AND 9051 to your OpenSim Server? (IF you have more regions, Add upon 9050 the number of needed ports)
    • Do you have set the next values in the file Regions.ini?
    • - InternalAddress = xxx.xxx.xxx.xxx (Your OpenSim Server IP Address)
      - InternalPort = 9051
      - ResolveAddress = false
      - ExternalHostName = SYSTEMIP
    • Do you have a True IPv4 connection from your Internet Service Provider?
    • Have you set the Firewall to accept data through these ports, both incoming and outgoing?

    Hopefully this will clear some issues.




  • Taarna_Welles
    Taarna_Welles
     Member
    Hello Neovo,

    We have followed your suggestions but we still have the same problem. The region is running smoothly since the major Metro update. In our log file,  on the 19th if August we saw the first message "string was not in a correct format". From that same date, I was not able to teleport to the region. Nothing changed at our side so I have no clue what we can do next.
  • Pius Noel
    Pius Noel
     Member
    I don't think it has to do with wrong port numbers or firewall settings. The error message clearly indicates an issue with a mismatch in the expected data format.

    You certainly need some support from the server admins to solve the problem. I would suggest to send an email to Gridmaster@metro.land and hope that @Lena Vanilli or @Sheera Khan will soon get back on you.
  • Pius Noel
    Pius Noel
     Member edited August 26
    Update: it seems to be a new known bug. I didn't find yet the time to read more about the details, but to me it sounds related to this one: http://opensimulator.org/mantis/view.php?id=8571

    Edit 10:50 CET: it looks like I can reproduce the issue on my Windows PC. I'll take a look at it later today.
  • Taarna_Welles
    Taarna_Welles
     Member
    @Pius Noel,
    Thank you for your feedback. I'll send an email to the gridmaster@metro.land.  I didn't have the email address. 
  • Taarna_Welles
    Taarna_Welles
     Member
    @Pius Noel,

    I installed a fresh install from Metro, but kept the same issue. Then my hubby followed the mantis you pointed to http://opensimulator.org/mantis/view.php?id=8571. In the mantis, we followed the workaround http://opensimulator.org/mantis/view.php?id=8549#c35475 and it seems it's the right solution. We also send an email to @Lena Vanilli of what we found.

    Best, Taarna  :) 
  • oddball otoole
    oddball otoole
     Member
    I had the same problem, followed the links provided above and got it working.
    Here's what I did:

    Open 
    OpenSim.exe.config, OpenSim32.exe.config and Robust.exe.config
     with a text editor. (I suggest notepad ++) and look for the <runtime> section.

    Look for this line: 
    <loadFromRemoteSources enabled="true" />

    Add this line below:
    <useLegacyJit enabled="1" />

    It should look like this:

    <runtime>
        <loadFromRemoteSources enabled="true" />
        <useLegacyJit enabled="1" />
      </runtime>

    Do this for all three files, save them and restart the server.

    Good luck!
    Thanked by: Pius Noel
Sign In or Register to comment.

Welcome

It looks like you're new here. If you want to get involved, click one of these buttons!

Discussions

© Copyright 2019 - Metropolis Metaversum
All times are GMT