Selbst gehostete Regionen | Self hosted Regions

Lena Vanilli
Lena Vanilli
 Administrator edited May 12 in General Themes
*** English Version below ***

Huhu Newbies,

ihr könnt eure selbst gehosteten Regionen an das Metropolis-Grid anschliessen. Wie das genau gemacht wird, kann man hier lesen: https://hypergrid.org/metropolis/wiki/de/index.php?title=SIM

Beim Anschluss einer selbst gehosteten Region wird für die Finanzierung der Grid-Services ein Kostenbeitrag von 1,50 Euro pro Monat erhoben. Dieser Kostenbeitrag wird monatlich automatisch beim Eigentümer der jeweiligen Region erhoben. 

Viel Spass!
Eure Admins


----------------------------------------------------
*** English Version ***

Huhu Newbies,

you can connect your self-hosted regions to the Metropolis Grid. How this is done exactly, you can read here: https://hypergrid.org/metropolis/wiki/en/index.php?title=SIM

When connecting a self-hosted region, the grid services will be charged a fee of 1.50 euros per month. This contribution is automatically collected monthly from the owner of the respective region.

Have fun!
Your admins


Comments

  • Lindalou Ellisson
    Lindalou Ellisson
     Member
    Hallo, ich habe versucht eine Region auf meinem PC zu installieren, Beim Start spricht er immer ab. Im Protokoll wird folgendes angezeigt:

    5-18 10:58:30,772 INFO  - OpenSim.Framework.Servers.BaseOpenSimServer [STARTUP]: Operating system version: Microsoft Windows NT 6.1.7601 Service Pack 1, .NET platform Win32NT, 64-bit

    2019-05-18 10:58:30,944 INFO  - OpenSim.OpenSim ====================================================================
    2019-05-18 10:58:30,944 INFO  - OpenSim.OpenSim ========================= STARTING OPENSIM =========================
    2019-05-18 10:58:30,944 INFO  - OpenSim.OpenSim ====================================================================
    2019-05-18 10:58:30,959 INFO  - OpenSim.Framework.Servers.ServerBase [SERVER BASE]: Starting in Z:\TRON-2\Online World\metropolis\metropolis-os_091_DEV_PLUS\bin
    2019-05-18 10:58:30,959 INFO  - OpenSim.Framework.Servers.ServerBase [SERVER BASE]: OpenSimulator version: OpenSim 0.9.1.0 Snail Metropolis Edition [20] Dev      
    2019-05-18 10:58:30,959 INFO  - OpenSim.Framework.Servers.ServerBase [SERVER BASE]: Operating system version: Microsoft Windows NT 6.1.7601 Service Pack 1, .NET platform Win32NT, 64-bit
    2019-05-18 10:58:30,975 INFO  - OpenSim.Framework.Servers.ServerBase [SERVER BASE]: Logging started to file Z:\TRON-2\Online World\metropolis\metropolis-os_091_DEV_PLUS\bin\OpenSim.log
    2019-05-18 10:58:30,975 INFO  - OpenSim.Framework.Servers.ServerBase [SERVER BASE]: Stats Logging started to file Z:\TRON-2\Online World\metropolis\metropolis-os_091_DEV_PLUS\bin\OpenSimStats.log
    2019-05-18 10:58:31,692 INFO  - OpenSim.Framework.Servers.HttpServer.BaseHttpServer [BASE HTTP SERVER]: Starting HTTP server on port 9000
    2019-05-18 10:58:31,708 ERROR - OpenSim.Framework.Servers.HttpServer.BaseHttpServer [BASE HTTP SERVER]: Error - Normalerweise darf jede Socketadresse (Protokoll, Netzwerkadresse oder Anschluss) nur jeweils einmal verwendet werden
    2019-05-18 10:58:31,708 ERROR - OpenSim.Framework.Servers.HttpServer.BaseHttpServer [BASE HTTP SERVER]: Tip: Do you have permission to listen on port 9000?
    2019-05-18 10:58:31,708 FATAL - OpenSim.Framework.Servers.BaseOpenSimServer Fatal error: System.Net.Sockets.SocketException (0x80004005): Normalerweise darf jede Socketadresse (Protokoll, Netzwerkadresse oder Anschluss) nur jeweils einmal verwendet werden
       bei OpenSim.Framework.Servers.HttpServer.BaseHttpServer.Start(Boolean performPollResponsesAsync, Boolean runPool)
       bei OpenSim.RegionApplicationBase.StartupSpecific()
       bei OpenSim.OpenSimBase.StartupSpecific()
       bei OpenSim.OpenSim.StartupSpecific()
       bei OpenSim.Framework.Servers.BaseOpenSimServer.Startup()

    Ich habe die Ports 8000, 9051 und 9000 jeweils UDP und  TCP  freigegeben ?
    In der Regions.ini habe ich folgende Einträge :


    [Lake_Saba]
     RegionUUID = 79d63b34-466e-4277-8e40-fa64b92d0871
     Location = "4650,4095"
     SizeX = 512
     SizeY = 512
     InternalAddress = "0.0.0.0"
     InternalPort = 9051
     AllowAlternatePorts = False
     ExternalHostName = "mentis.hopto.org"
     MaxPrims = 50000

    was mache ich falsch?

    Als Router ist eine Fritzbox 7590 XF in Betrieb

    Liebe Grüße Linda
  • Sheera Khan
    Sheera Khan
     Member edited May 18
    Hallo Linda,

    laut Protokoll bricht der OpenSim-Prozess ab, wenn er versucht, den Port 9000 zu öffnen. Das kann entweder ein Problem mit den Berechtigungen des Benutzers sein, in dessen Namen der Server statet oder der Port ist bereits durch einen anderen Prozess belegt.

    2019-05-18 10:58:31,692 INFO  - OpenSim.Framework.Servers.HttpServer.BaseHttpServer 
    [BASE HTTP SERVER]: Starting HTTP server on port 9000
    2019-05-18 10:58:31,708 ERROR - OpenSim.Framework.Servers.HttpServer.BaseHttpServer 
    [BASE HTTP SERVER]: Error - Normalerweise darf jede Socketadresse (Protokoll, Netzwerkadresse oder Anschluss) nur jeweils einmal verwendet werden
    2019-05-18  10:58:31,708 ERROR - OpenSim.Framework.Servers.HttpServer.BaseHttpServer 
    [BASE HTTP SERVER]: Tip: Do you have permission to listen on port 9000?
    Kannst Du da mal nachschauen, ob da nicht noch ein alter Prozess läuft?

    Ciaoo

    Sheera
  • Lindalou Ellisson
    Lindalou Ellisson
     Member
    Hallo Sheera, ja das wars , Port 9000 war belegt nach der Freigabe des Port startete die neue Region problemlos. Alledings habe ich nun ein neues Problem: Ich komme nicht auf die Region. Ich verfüge über zwei Internet Zugänge daher auch zwei IP Adressen.  Die Region läuft auf der ersten IP und mit der zweiten IP geht mein Ava online. (Um die sen NAT-Loupback auszuschließen. Hast du noch ein Tip ? Die region Lake_Saba kann ich in der Karte sehen . Liebe Grüße Linda
  • Sheera Khan
    Sheera Khan
     Member
    Hmmm, "Service Request failed. The Operation has timed out." Das sieht nach einer Firewall auf Deinem Server oder einer nicht funktionierenden Weiterleitung auf dem Router aus. Magst Du die Konfiguration (Port-Weiterleitung) des Routers, an dem der Server hängt, nochmal überprüfen?
    Oder ist IPv6 bei Dir aktiviert worden?

    Ciaoo

    Sheera
  • Lindalou Ellisson
    Lindalou Ellisson
     Member
    Ich habe die ports nochmal überprüft, Port 8000, 9000 und 9051 habe ich freigegeben für udp und tcp. auch habe ich für einen versuch die firewall ausgeschaltet, IP6 ist nicht aktiviert , auf keinem meiner rechner. Man kann immer noch nicht auf die Region ... Hast du noch eine Idee?

  • kalle_klick
    kalle_klick
     Member
    ACHTUNG bei neueren 64-bit Windows-Versionen (z.B. Windows 7,
    Windows 2008 Server)! Falls es zu Problemen beim
    Betreten von Regionen kommt z. B. service
    request failed: Error: ConnectFailure (No route to host), sollte eine
    generelle Firewall-Freigabe für OpenSim.exe erteilt
    werden. Hier ist Die Windows Firewall gemeint !! (Vorgehensweise: Systemsteuerung,
    Firewall, Ein Programm
    oder Feature durch die Windows Firewall zulassen,
    OpenSim.exe auswählen, Port = beliebiger Port)

  • Sylvia Sonoda
    Sylvia Sonoda
     Member
    Just my two cents here: I see External HostName = "mentis.hopto.org"
    Is that name via dns set to your hosting machines ip address?
    Maybe for testing make it   External HostName = 88.99.77.22  *
    * example digits. The digits must be your hosting machines internet connection IP
    So NOT internal address router ip's. You can check your hosting machines IP address here: www.swondo.com/ip   Be sure to check IP with a browser running on the same network as the "sim hosting" computer.
  • Eryn Galen
    Eryn Galen
     Member
    Für den Fall, dass du kein Englisch kannst, LindaLou: Ersetze mal das "mentis.hopto.org" durch deine IP Adresse. Diese kannst du u.a. hier kriegen: https://www.whatismyip.com/de/


  • Etstu_Lirew
    Etstu_Lirew
     Member
    Wie sieht es denn mit der Bezahlung der Regionen aus? Ich habe bis heute keine Rechnung für meine Regionen erhalten.
  • Eryn Galen
    Eryn Galen
     Member
    Kannst ja trotzdem schon zahlen - da hält dich ja keiner von ab
  • Mareta Dagostino
    Mareta Dagostino
     Member edited June 19
    Naja, ganz so einfach ist es nicht: Außer den Mietern, die direkt bei den Admins Regionen bestellt haben, kennen wir keine Bankverbindung oder PayPal Konto der Hypergrid Virtual Solutions UG. bisher hatten die Admins immer ein Tool programmiert, beispielsweise zum Avatar verifizieren. Da brauchte man als Resident nur drauf klicken und sich nicht selber ein Konto auswählen.

    Was natürlich immer geht ist Spenden. :)

    Update:
  • wolfstep
    wolfstep
     Member edited August 12
    Hello, I brought 4 regions online the other day. Because of a self-inflicted stupid mistake, I had to reboot my linux server. The region's I was using on my system were refused by yours because they already existed.  I had to change my location and change their names. How do I keep this from happening? To keep changing my region name and location is a pain.
  • Mareta Dagostino
    Mareta Dagostino
     Member
    Hi wolfstep. You can do these steps:
    1) Stop OpenSim.
    2) Delete your regions from the grid with the Web tool: https://metro.land/metropolis/regioman.php
    3) Start OpenSim.

    Kind regards, Mareta

  • wolfstep
    wolfstep
     Member edited August 21
    Mareta,
    After some consternation, I thought it wise to reread the setup pages and saw that the regions have to be manually removed through the web page. Great for manually taking them off line, but takes the wind out of my sails if I am away, power is lost to storms and the UPS dies before it comes back on. (bless our midwest storms)
    I was hoping to setup an autoboot scenario for my unix servers. Oh well. Is what it is. Any how thanks so much for replying. Truly appreciate it.


    Bob
  • Mareta Dagostino
    Mareta Dagostino
     Member
    Hi Bob,

    if after a reboot all the data position, name and UUID of a region are the same, there is no need to do anything in the web tool. The region will pop up again. I do an automatic server reboot each night with a brute force "shutdown -r now" in a cron job. (So if something crashes and I'm away, latest after 24 hours it is back again.)

    Manual deletion in the web tool is only necessary if you want to create the "same" region on another position. That is an intended security feature, otherwise any other people (me for example) could hijack your region if your server goes down (for example by attack). Or they could simply take over your map position removing your region from the grid and setting up their own instead.

    Kind regards,
    Mareta

Sign In or Register to comment.

Welcome

It looks like you're new here. If you want to get involved, click one of these buttons!

Discussions

© Copyright 2019 - Metropolis Metaversum
All times are GMT